Announcement

Collapse
No announcement yet.

HRD 633 and now 638 fails with ICOM IC-7300

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HRD 633 and now 638 fails with ICOM IC-7300

    Prior to 633 HRD worked fine with my IC-7300. Since 633 and now 638, HRD is not properly managing the IC-7300.

    1. Can't select USB or USB-D (it shows on the radio front panel but not in the software) - The problem is that DATA is messed up as HRD seems to think it's in one mode while the radio is in another. If I use another app, data is exchanged properly.

    2. The frequency display switches to a memory channel then returns ... as if there was a "guard channel" or some form of scanning ... but there isn't any as this function is not configured and this didn't happen with earlier versions of HRD.

    3. The same as noted in 1 and 2 above are seen in both RADIO CONTROL and DM780

    Other apps work fine (WSPR, JT65, MultiPSK, etc.) but my main app is HRD and it's now useless to me.

    Any suggestions as to what I can do to remedy this?

    Computer is running in Windows 10 Home x64 w/current pushed updates. Problems started with 633 and continues with 638. I am hoping it's something on my end ;-)

  • #2
    I am using version 636 and I am able to select USB and USB-D and it shows the same info on the rig. I select Mode:USB then Data:ON

    Comment


    • #3
      Originally posted by sieb View Post
      I am using version 636 and I am able to select USB and USB-D and it shows the same info on the rig. I select Mode:USB then Data:ON
      That's how it used to work. I'll do a full uninstall and start from scratch. Must be something that happened during a Microsoft or HRD update. I know it's not the radio as other software packages work just fine with the IC-7300. So ... I'll report back once I figure out how to fix it :-)

      Comment

      Working...
      X